Parsitem

وب سایت شخصی مهندس رامین ملک قاسمی

مقالات شبکه و کامپیوتر

بايگاني براي ژانویه, 2014

vlan-8021q

http://www.firewall.cx/networking-topics/vlan-networks/221-vlan-8021q-analysis.html

نوشته شده به وسيله ramin_malek در Cisco ، ديدگاه ‌ها (822)

دریافت یوزر و پس روزانه Node 32

http://nod32ir.tk

نوشته شده به وسيله ramin_malek در هک و عملیات DDOS ، ديدگاه ‌ها (97)

نقشه Groove

http://www.rmalekghasemi.ir/file/groove.pdf

نوشته شده به وسيله ramin_malek در Wireless ، ديدگاه ‌ها (811)

Connection Tracking یا پیگیری کانکشن ها در میکروتیک

http://wiki.mikrotik.com/wiki/Manual:IP/Firewall/Connection_tracking#Features_affected_by_connection_tracking

نوشته شده به وسيله ramin_malek در شبکه(mikRotik Routers) ، ديدگاه ‌ها (1,371)

How Load Balancing In mikrotik

http://wiki.mikrotik.com/wiki/Load_Balancing

نوشته شده به وسيله ramin_malek در شبکه(mikRotik Routers) ، ديدگاه ‌ها (1,067)

Voice Over cisco

http://www.persianadmins.ir/v2/articles/cisco/cisco-list/372-cisco-voip-site-to-site.html

نوشته شده به وسيله ramin_malek در Cisco ، بدون ديدگاه

IP Tunnel Mikrotik And cisco

http://www.persianadmins.ir/v2/articles/cisco/cisco-list/104-cisco-mikrotik-ipip-tunnel.html

نوشته شده به وسيله ramin_malek در Cisco ، بدون ديدگاه

Inter Vlan Routing

در ابتدا تنظیمات سوییج های 2960 را انجام میدهیم:

شامل ساختن vlanها و سپس تخصیص پورتهای مربوط به آنها.بطور مثال بر روی سوییچ یک:

Switch(config)#vlan 2
Switch(config-vlan)#vlan 3
Switch(config-vlan)#int f0/2
Switch(config-if)#switchport access vlan 2
Switch(config-if)#int f0/3
Switch(config-if)#switchport access vlan 3

Switch(config-if)#int f0/1
Switch(config-if)#switchport mode trunk

سپس بر روی سوییچ 3560 تنظیمات زیر را انجام میدهیم:

Switch(config)#ip routing
Switch(config)#int vlan 2
Switch(config-if)#ip add 192.168.1.100 255.255.255.0
Switch(config-if)#int vlan 3
Switch(config-if)#ip add 192.168.2.100 255.255.255.0

نکته: بر روی تمامی سوییچ ها باید پورتهای اتصال دهنده ی سوییچ ها به یکدیگر در مد trunk پیکربندی شود.

نکته: vlanهای 2 و 3 را بروی سوییچ 3560 هم ایجاد می کنیم.

نکته: ip آدرسهایی که به ایترفیسهای ایجاد شده در سوییچ 3560 اختصاص می دهیم را باید به عنوان default gateway  بر روی pcها انتخاب کنیم.مثلا در اینجا 192.168.1.100 را بعنوان default gateway کلاینتهای vlan2 و آدرس 192.168.2.100 را بعنوان default gateway برای کلاینتهای vlan3 تعیین می کنیم.

*اکنون ارتباط بین تمامی vlanها با یکدیگر برقرار است.

نوشته شده به وسيله ramin_malek در Cisco ، ديدگاه ‌ها (133)

ایجاد تونل بین 2 سیسکو

در این سناریو، وضعیت ارتباطی دو شبکه LAN مربوط به دو Branch Office  به نحوی پیکربندی شده که یک بسته اطلاعات برای انتقال از یک Branch به Branch دیگر ملزم به عبور از روتر های شرکت مخابرات خواهد بود. از آنجا که شرکت مخابرات تعهدی در قبال ترانزیت بسته های اطلاعات مشتریان با Source IP شبکه محلی مشتریان ندارد، لذا جهت ارتباط کلاینت های داخل شبکه های محلی دو راهکار پیش رو خواهد بود. راه اول استفاده از مکانیزم Duble NAT میباشد که در ترافیک بالا باعث ایجاد Load بسیار زیادی بر روی CPU روتر ها خواهد شد. راه دوم ایجاد یک Tunnel مجازی بصورت Point To Point میان دو Border Router شبکه های محلی راه دور می باشد که در این بخش قصد دارم نحوه پیکربندی آن را بصورت Step by step تشریح نمایم. 

 

تشریح صورت مسئله: 

     برای واضح تر شدن صورت مسئله، به دیاگرام زیر توجه کنید. در این سناریو دو کاربر iman و armin می خواهند بدون توجه به پیچیدگی شبکه WAN بر قرار شده میان دو Branch Office دو سوی شبکه intranet، با یکدیگر ارتباط بر قرار کنند. در دیاگرام زیر NET ID مربوط به هر Branch Office مشخص و اطلاعات NET ID شبکه WAN بر روی هر Router درج شده.

 

      هدف از اجرای Tunnel Channel بر روی بستر WAN مهیا شده، برقراری امکان دسترسی مستقیم کلاینت Armin به کلاینت Iman با Source IP شبکه LAN سمت چپ دیاگرام می باشد.

 

 

 

Iman Mojtahedin- CCNA- Tunneling

 

 

 

مرحله اول  :   ایجاد اینترفیس Tunnel

 

برای ایجاد اینترفیس Tunnel دستورات زیر را خط به خط در مود Configuration روتر وارد کنید:

دقت کنید در قطعه کد زیر، دستورات برای پیکربندی روتر سمت چپ (Armin) تنظیم شده و دقیقا همین پیکربندی برای روتر سمت راست (Iman) نیز با رعایت تغییرات لازم در آدرس های Source و Destination لازم است. در ضمن IP Address سمت دیگر باید 10.10.10.2 تنظیم شود.

 

Left router : 
interface Tunnel0
 description Tunnel Over WAN(iman-armin)
 ip address 10.10.10.1
 tunnel source 217.219.47.1
 tunnel destination 85.185.93.1

Right router : 
interface Tunnel0
 description Tunnel Over WAN(iman-armin)
 ip address 10.10.10.2
 tunnel source 85.185.93.1
 tunnel destination 217.219.47.1
مرحله دوم : ویرایش جدول مسیر یابی روتر

جدول مسیر یابی روتر سمت چپ (Armin) باید بصورت زیر ویرایش شود:

armin(config)#ip route 217.219.47.0 255.255.255.252 serial0/0/0
armin(config)#ip route 172.32.32.0 255.255.255.0 10.10.10.2

و جدول مسیریابی روتر سمت راست (Iman) نیز بصورت زیر پیکربندی خواهد شد:
iman(config)#ip route 85.185.93.0 255.255.255.252 serial0/0/0
iman(config)#ip route 192.168.1.0 255.255.255.0 10.10.10.1


در این مرحله پیکربندی Tunnel Channel به پایان رسیده و در صورت Up بودن اینترفیس های Serial در دو طرف، ارتباط مستقیم شبکه های LAN از داخل Tunnel ایجاد شده برقرار خواهد شد.

نوشته شده به وسيله ramin_malek در Cisco ، ديدگاه ‌ها (784)

HSRP Protocol

HSRP مخفف Hot Standby Routing Protocol بوده و پروتکلی مخصوص شرکت سیسکو میباشد. از این پروتکل بمنظور افزونگی (redundancy) استفاده میشود.
استاندارد مشابهی به نام VRRP یا Virtual Router Redundancy Protocol نیز وجود دارد که سیسکو آن را نیز پشتیبانی میکند.
در تمام شبکه های محلی (LAN) تمام Host ها برای ارتباط با بیرون از شبکه از یک آدرس default gateway استفاده میکنند که اگر این default gateway دچار مشکل شود ارتباط شبکه با بیرون نا ممکن خواهد شد . با HSRP ما میتوانیم دو دستگاه روتر Gateway داشته باشیم : یکی فعال و دیگری به حالت انتظار (Standby) .تا چنانچه برای gateway فعال مشکلی پیش آمد،آن gateway که در حالت انتظار (Stand by ) است جای آن را بگیرد . در این حالت هر روتر دارای یک آدرس ip فیزیکی است که روی اینترفیسی که به lan متصل می شود تنظیم می گردد. اما همچنین هر دو روتر دارای یک آدرس ip مجازی (HSRP address) نیز هستند که به عنوان default gateway برای Host های Lan مورد استفاده قرار میگیرد.مهم نیست که کدام روترgateway (چه روتر فعال یا چه روتر standby یا پشتیبان) up باشند آدرس HSRP مجازی در هر حالت یکی است.

اکنون به پیکربندی این سناریو می پردازیم:

برای سوییچ لایه سه “0” :

Switch(config)#ip routing

Switch(config)#int f0/1

Switch(config-if)#no switchport

Switch(config-if)#ip address 192.168.1.100 255.255.255.0

Switch(config-if)#int f0/2

Switch(config-if)#no switchport

Switch(config-if)#ip address 192.168.0.1 255.255.255.0

Switch(config-if)#exit

Switch(config)#int f0/1

Switch(config-if)#standby 1 ip 192.168.1.1

Switch(config-if)#standby 1 priority 200

Switch(config-if)#standby 1 preempt

Switch(config-if)#standby 1 timers 2 6

Switch(config-if)#standby 1 autnentication ccnp

 

Switch(config)#ip route 0.0.0.0 0.0.0.0 f0/2

 

وبرای سوییچ لایه سه “1” :

Switch(config)#ip routing

Switch(config)#int f0/1

Switch(config-if)#no switchport

Switch(config-if)#ip address 192.168.1.101 255.255.255.0

Switch(config-if)#int f0/2

Switch(config-if)#no switchport

Switch(config-if)#ip address 192.168.10.1 255.255.255.0

Switch(config-if)#exit

Switch(config)#int f0/1

Switch(config-if)#standby 1 ip 192.168.1.1

Switch(config-if)#standby 1 priority 200

Switch(config-if)#standby 1 preempt

Switch(config-if)#standby 1 timers 2 6

Switch(config-if)#standby 1 autnentication ccnp

 

Switch(config)#ip route 0.0.0.0 0.0.0.0 f0/2 

مدیریت و مشاهده وضعیت پروتکل HSRP:

sh run

sh standby

sh standby brief

عیب یابی پروتکل HSRP:

debug standby#

debug standby errors#

debug standby events#

نوشته شده به وسيله ramin_malek در Cisco ، ديدگاه ‌ها (87)

 Parsitem