Parsitem

وب سایت شخصی مهندس رامین ملک قاسمی

مقالات شبکه و کامپیوتر

بايگاني براي جولای, 2013

http://www.rmalekghasemi.ir/file/exchange2010[ebook.VeyQ.ir].pdf

نوشته شده به وسيله ramin_malek در شبکه ، بدون ديدگاه

محل قرار گرفتن مخازن در لینوکس

/etc/yum.repos.d

نوشته شده به وسيله ramin_malek در Linux ، ديدگاه ‌ها (885)

Q in Q

فرض میکنیم که سویچ های ۱ و ۴ سمت مشترک هستند و سویچ های ۲ و ۳ Service Provider می باشند.

Provider با یک پورت Access که عضو Vlan 100 است به مشترک متصل است.

Provider از Vlan های مشترک اطلاعی ندارد(۱۴و۴۱) پس روتر ۴ با روتر ۱ نمی توانند با هم ارتباطی داشته باشند برای برقراری ارتباط روتر ها Provider از Q.in.Q Tunneling استفاده میکند.

برای دیدن سایز بزرگ روی عکس کلیک کنید

نام:  Q-In-Q.png
مشاهده: 44
حجم:  103.1 کیلو بایت

R1
interface FastEthernet0/0
no shutdown
!
interface FastEthernet0/0.14
encapsulation dot1Q 14
ip address 14.0.0.1 255.255.255.0
!
interface FastEthernet0/0.41
encapsulation dot1Q 41
ip address 41.0.0.1 255.255.255.0
R4
interface FastEthernet0/1
no shutdown
!
interface FastEthernet0/1.14
encapsulation dot1Q 14
ip address 14.0.0.4 255.255.255.0
!
interface FastEthernet0/1.41
encapsulation dot1Q 41
ip address 41.0.0.4 255.255.255.0

SW1
system mtu 1504
!
interface FastEthernet0/1
switchport access vlan 100
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
no cdp enable
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk
SW2
system mtu 1504
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport mode trunk
SW3
system mtu 1504
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
SW4
system mtu 1504
!
interface FastEthernet0/4
switchport access vlan 100
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
no cdp enable
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport mode trunk
R4#show cdp neighbor
Capability Codes: R – Router, T – Trans Bridge, B – Source Route Bridge
S – Switch, H – Host, I – IGMP, r – Repeater
Device ID Local Interface Hold time Capability Platform Port ID
R1 Fas 0/1 ۱۲۵ R S I ۲۶۱۰XM Fas 0/0

روتر ۴ روتر ۱ را Direct Connected میبیند
نکته:دوستان عزیز این سناریو را با Real Rack انجام دادم

برای اطلاعات بیشتر http://blog.shafagh.com/persian/2008/08/01/ccie-lab-8021q-tunneling
http://www.cisco.com/en/US/docs/swit…/swtunnel.html
 

 

منیع آلخمیس

نوشته شده به وسيله ramin_malek در Cisco ، ديدگاه ‌ها (798)

Best audio Recorder

http://audacity.sourceforge.net

نوشته شده به وسيله ramin_malek در عمومی ، ديدگاه ‌ها (1)

MPLS چیست

MPLS و ساختار آن

 

 

به نام خدا

ام پی ال اس

alooirandotir

سوئیچ برچسب و MPLS

 در خلال زمانی که IETF بر روی موضوع « خدمات مجتمع » کار می کرد، چندین تولید کننده محصولات مسیریابی نیز بر روی روشهای بهتر هدایت بسته ها متمرکز شده بودند. کار آنها بر این محور بود که در ابتدای هر بسته یک   « برچسب » (Label) اضافه شود و بجای آنکه مسیریابی و هدایت بسته ها مبتنی بر آدرس مقصد باشد بر اساس این « برچسب » انجام شود. با استفاده از این « برچسب » به عنوان یک اندیس در جدول داخلی هر مسیریاب، خط خروجی صحیح و مناسب برای هر بسته پیدا می شود. بکمک این روش مسیریابی بسته ها به سرعت انجام شده و منابع مورد نیاز در طول مسیر رزرو خواهد شد.

البته برچسب گذاری بر روی هر « جریان » شباهت عجیبی به مدارهای مجازی پیدا می کند. در شبکه های  ATM Frame Relay , x,25 ، یا هر زیر شبکه مدار مجازی دیگر نیز یک « برچسب » ( یا به عبارتی یک شناسنامه مدار مجازی) در هر بسته قرار داده می شود و با استفاده از آن به عنوان یک اندیس برای درایه های جدول مسیر مناسب بدست می آید.

 علیرغم  آنکه بسیار از افراد در جامعه اینترنت از شبکه های اتصال گرا بشدت گریزان هستند به نظر می رسد که این ایده با هدف مسیریابی سریع و تامین کیفیت خدمات ( QOS )  بار دیگر به صحنه برگشته است. ولیکن بین روشی که در اینترنت برای تعین مسیر بکار می رود و روشی که در شبکه های مدار مجازی اعمال می شود تفاوتهای بنیادی وجود دارد و تکنیک برچسب گذاری بسته ها با روش سنتی سوئیچینگ متفاوت است.

ایده جدید سوئیچینگ با نامهای متنوعی مثل   « سوئیچینگ برچسب  »  ( Label Switching ) یا « سوئیچینگ علامت » ( Tag Switching )شناخته می شود. در نهایت IETF آن را تحت نام MPLS (Multi-Protocol Label Switching) استاندارد کرد   این استاندارد در RFC 3031  و چندین RFC دیگر تشریح شده است.

مضاف بر این برخی افراد بین « مسیریابی» و « سوئیچینگ» فرق می گذارند. مسیریابی فرآیند جستجو در جدول مسیریابی به دنبال آدرس مقصد هر بسته و پیدا کردن خط مناسب برای آن است. برعکس در فرآیند سوئیچینگ از برچسب هر بسته به عنوان یک اندیس در جدول مسیریابی استفاده می شود و با استفاده از این اندیس بلافاصله خط خروجی پیدا می شود، بدون آن که نیازی به جستجو باشد. البته این تعاریف و تعابیر جهان شمول و همگانی نیستند.

اولین مسئله آنست که این برچسب در کجا قرار داده شود. از آنجایی که بسته های IP برای شبکه های مدار مجازی طراحی نشده بودند، طبعا هیچ فیلدی در سرآیند بسته IP برای درج شماره های مدار مجازی وجود ندارد. به همین دلیل سرآیند جدید MPLS باید در جلوی سرآیند هر بسته IP قرار بگیرد. در خطوط مستقیم بین هر دو مسیریاب که مبتنی بر           « فریمینگ PPP  » کار می کنند.

ترتیب سرآیند ها طبق شکل ۱ عبارتند از : سرآیند PPP ، سرآیند MPLS سرآیند IP و نهایتا سرآیند TCP . در واقع باید MPLS را در لایه ۵/۲ فرض کرد .

 (شکل ۱)

ام پی ال اس

alooirandotir


سرآیند عمومی (MPLS Header) MPLS چهار فیلد دار د که مهمترین آنها فیلد Label ( فیلد برچسب) است که در آن یک اندیس درج می شود. فیلد  QOS کلاس خدمات را مشخص می کند فیلد S بدان منظور تعریف شده که در شبکه های سلسه مراتبی چندین سرآیند MPLS متوالیا به بسته اضافه گردد.

فیلد TTL زمان حیات بسته را مشخص می کند و به ازای هر گام یک واحد از آن کم می گردد هر گاه مقدار این فیلد به صفر برسد بسته حذف می شود. این ویژگی بدان منظور مفید است که از حلقه بی نهایت که در اثر ناپایداری ( عدم همگرایی) جدول مسیریابی بروز می کند اجتناب شود.

از آنجایی که سرآیند MPLS بخشی از بسته لایه شبکه یا فریم لایه پیوند داده ها محسوب نمی شود لذا MPLS تا حد زیادی مستقل از هر دو لایه است. از بین تمام محاسن دیگر، دستاورد ویژگی«استقلال از دیگر لایه ها»  آنست که می توان سوئیچیهای MPLS را به گونه ای ساخت که بتواند هم بسته های IP و هم سلولهای ATM را برحسب مورد هدایت کند. این ویژگی همانی است که براساس آن کلمه  Multi protocol در ابتدای نام MPLS  ظاهر شده است.

وقتی یک بسته یا سلول غنی شده با سرآیند MPLS در یک مسیر یاب MPLS دریافت می شود از برچسب آن به عنوان اندیسی در جدول داخلی مسیریاب استفاده شده و خط خروجی متناسب با آن تعیین می شود و قبل از خروج بسته از آن خط برچسب جدیدی در فیلد مربوطه درج می گردد. تغییر در برچسبها در تمام زیر شبکه های مدار مجازی معمول و متعارف است چرا که برچسبها در هر مسیریاب معنای محلی دارند و دو مسیریاب متفاوت ممکن است بسته های نامربوط را با برچسبی یکسان برای مسیریاب دیگر بفرستند چرا که این بسته ها همگی در بخشی از مسیر مشترکند. به همین دلیل در هر گام برچسبهای بسته قبل از انتقال بر روی خط خروجی به برچسب جدید و معتبر در مسیر یاب بعدی نگاشته می شود. این مکانیزم را در شکل ۲ مشاهده می کنیم.

در MPLS  نیز از روش مشابهی بهره گرفته شده است.

( شکل۲)

شبکه

یکی از تفاوتهای  MPLS  با شبکه های مدار مجازی ،  «  میزان تجمیع   »   Aggregation Level )  (و صرفه جویی در تعداد درایه های جدول مسیریابی است. در MPLS این امکان وجود دارد که هر « جریان » در زیر شبکه دارای مجموعه برچسبهای خاص خود باشد ولی این قابلیت مهم نیز وجود دارد که گروهی از جریانها که همگی به یک مسیریاب خاص خود یا یک LAN ختم می شوند با برچسب یکسان و واحدی مشخص شوند. ‍‌[ بدین ترتیب تعداد درایه های جدول مسیریابی کاهش یافته و اصطلاحا عمل تجمیع یا AGGREGATION انجام می شود.] گروهی از جریانها که یک برحسب واحد مشخص می شوند اصطلاحا به یک FEC( Forwarding Equivalence Class)مشابه متعلق هستند [ یعنی همه آنها به یک طریق هدایت می شوند.] کلاس FEC نه تنها مقصد همه بسته ها را مشخص می کند بلکه کلاس خدمات موردنیازآنهارانیز تعیین می نماید.از دیدگاه انواع خدمات متمایز طبعا فرآیند هدایت تمام بسته های یک FEC یکسان خواهد بود.

در مسیر متعارف به روش مدار مجازی ، این قابلبت که بتوان چندین مسیر مجزا با نقاط پایانی متفاوت را با شناسه مدار مجازی واحد مشخص کرد و جود ندارد چرا که در این صورت راهی برای مشخص کردن مقصد نهایی بسته ها وجود نخواهد داشت در حالی که در MPLS بسته ها [ به غیر از سرآیند ۴ بایتی MPLS ] آدرس واقعی ماشین مقصد را نیز با خود حمل می کنند و بدین ترتیب در انتهای مسیری که با برچسب مشخص شده می توان سرآیند حاوی برچسب را حذف کرد و هدایت بسته ها به روش معمول و مبتنی بر آدرس لایه شبکه [ مثل آدرس IP] ادامه داد.

یکی از تفاوتهای بنیادی بین MPLS و شبکه های مدار مجازی در چگونگی تشکیل جداول مسیریابی است.

 در شبکه های مدار مجازی وقتی یک کاربر بخواهد یک « اتصال » ایجاد کند، توسط لایه شبکه یک بسته خاص جهت تنظیم مسیر به زیر شبکه روانه می شود تا ضمن ایجاد یک مسیر درایه های لازم در جداول مسیر یابی درج شود.

در MPLS بدین نحو عمل نمی شود چرا که درآن عمدا هیچ مرحله ای برای تنظیم اتصال پیش بینی نشده است.  (زیرا در غیر این صورت نرم افزارهای موجود اینترنت دچار شکاف و ناسازگاری می شد. )

در عوض برای تنظیم و ایجاد درایه های جدول مسیریابی از دو راهکار جدید استفاده شده است.

در راهکار اول که روش متکی به داده (Data driven)  نامیده می شود هر گاه بسته ای در اولین مسیر یاب دریافت شود، آن مسبر یاب واقع بر روی مسیر جریان، تماس گرفته و از او می خواهد که یک برچسب برای این جریان ایجاد نماید.

 این فرآیند به صورت بازگشتی (Recursive)  ادامه می یابد تا مجموعه برچسبها ایجاد شوند. در واقع این روش را می توان ایجاد « مدار مجازی برحسب تقاضا» فرض کرد.

پروتکلهایی که عمل برچسب دهی را انجام می دهند مراقب هستند تا از بروز حلقه اجتناب شود.

 برای این کار از تکنیکی به نام « ریسمانهای رنگی » (Colored Thread)  بهر ه گرفته می شود . انتشار معکوس یک FEC  را می توان با یک ریسمان رنگی و یکتا (تمثیلی از یک مسیر در شبکه) در زیر شبکه مقایسه کرد. اگر مسیریاب رنگی را مشاهده کند که خودش نیز به همان رنگ است متوجه می شود که در انتخاب مسیر حلقه ایجاد شده وبرای رفع آن اقدام می کند.

 به عبارت بهتر اگر یک مسیر بین دو نقطه را در غالب یک ریسمان رنگی مجسم کنید هر بسته که با رنگ همان مسیر دو بار دریافت شود نشان می دهد که بسته در یک حلقه قرار گرفته است وگرنه با ید تا رسیدن به مقصد راه خود را ادامه دهد.

روش « برچسب دهی متکی به داده » (Data driven)  در شبکه هایی کاربرد دارد که زیر ساخت انتقال آنها ATM  است. ( همانند بیشتر سیستمهای تلفن)

راهکار دیگر برای برچسب دهی به جریان داده ها ، در شبکه هایی کاربرد دارد که زیر بنای آنها ATM نیست این روش اصطلاحا روش متکی به کنترل (Control Driven)  نامیده می شود که گونه های متنوعی از آن وجود دارد یکی از این گونه ها به ترتیب ذیل عمل می کند:

 وقتی یک مسیریاب راه اندازی ( بوت) می شود ابتدا بررسی می کند که در انتهای چه مسیرهایی قرار دارد ( یعنی مثلا چه ماشینهایی بر روی LAN متصل به او قرار دارند) سپس برای تمام آنها یک یا چند FEC (شناسه یک گروه با کلاس معادل) تولید کرده و ضمن تخصیص یک برچسب به هر یک از این گروهها آنها را به همسایه های خود اطلاع می دهد آنها نیز به ترتیب برچسب ها رادر جدول مسیر یابی خود وارد کرده  و با تعیین برچسبی جدید متناظر با هر برچسب قبلی آنها رابه همسایه های خود اطلاع می دهند تا آنکه تمام مسیریابها از مسیرهای جدید اگاه شوند. در حین ایجاد مسیر می توان منابع لازم را نیز برای تضمین کیفیت خدمات رزرو کرد.

در MPLS می توان بطور همزمان در چندین سطح عمل کرد. در بالاترین سطح، هر زیر شبکه حامل را می توان یک نوع Metarouter فرض کرد که بین هر مبداء و مقصد مسیری وجود دارد که از این متاروترها می گذرد در این مسیر از MPLS استفاده می شود.

یعنی مسیر بین مبدا و مقصد از زیر شبکه های متفاوتی م گذرندکه هر یک از این زیر شبکه ها حامل یک مسیر یاب واحد به نام >متاروتر< فرض شده است .

با این حال در درون یک زیر شبکه حامل نیز می توان از MPLS بهره گرفت و بدین ترتیب مسیر یابهای داخلی نیز برچسب دومی به هر بسته می افزایند و برچسب گذاری سطح دوم پدید می آید.

 در حقیقت یک بسته می تواند دنباله ای از برچسبهای MPLS را به همراه داشته باشد.

 بیت S در شکل ۶ مسیر یاب را آگاه می کند که آیا برچسبهای دیگری هم وجود دارد.

 در آخرین برچسب بیت S یک است در حالیکه در بقیه برچسبها بیت S صفر می باشددر عمل می توان از این قابلیت برای پیاده سازی VPN یا تونلهای بازگشتی (Recursive Tunnel) بهره گرفت.

 معماری MPLS

 به جرأت می توان گفت فن آوری MPLS ، که توسط گروه مطالعاتی IETF ارائه و توسعه یافته است، آخرین تحول در سوئیچینگ چند لایه می باشد . در MPLS که از مدل کنترل رانده برای اختصاص و توزیع برچسب استفاده می نماید ، مسیرهای ارسال اطلاعات (LSP) به خودی خود یک طرفه می باشند و برای ارسال ترافیک های دو طرفه باید دو LSP مختلف بین مبدأ و مقصد ایجاد گردد .

در MPLS ، از مسیریابی استاندارد IP و همچنین از الگوریتم جابجایی برجسب ، برای هدایت بسته ها استفاده می نماید.

 یکی از ویژگی های بارز MPLS ، آن است که متکی بر پروتکل مشخصی در لایه پیوند داده نمی باشد ؛ بلکه بر روی هر فن آوری ، لایه دومی قابل نصب است.

چنانچه پروتکل لایه دوم دارای فیلد برچسب باشد ( مانند فیلدهای DLCI , VPI/VCI در ATM و Frame Relay ) ، از همان فیلد برای اختصاص فیلد بر چسب MPLS استفاده می شود و در غیر این صورت از قسمتی از ناحیه سرآیند بسته های MPLS ، که بین سرآیندهای لایه دوم و لایه IP قرار دارد ، به عنوان فیلد برچسب استفاده می شود .

در سرآیند MPLS فیلدهای زیر موجود است .

  • فیلد برجسب به طول ۲۰ بیت ، که حاوی مقدار واقعی برچسب MPLS می باشد .
  • فیلد سه بیتی کلاس خدمات (QOS) ، که به کمک آن می توان نحوه صف بندی و حذف بسته ها در هنگام عبور از سوئیچ های شبکه را مشخص نمود .
  • فیلد یک بیتی S ، که نشان دهنده پایان ناحیه پشته برچسب می باشد . چنانچه این بیت یک باشد ، به معنی آن است که برچسب جاری ، آخرین برچسب ناحیه پشته است .
  • فیلد ۸ بیتی زمان زندگی (TTL) که مطابق با فیلد TTL بسته های IP عمل می نماید .

در طراحی MPLS اهداف زیر مورد توجه می باشد :

۱– MPLS باید قادر به پشتیبانی از هر نوع فن آوری لایه دوم باشد و فقط منحصر به ATM و Frame Relay نشود .

۲– MPLS باید با پروتکل های مختلف مسیریابی سازگار باشد .

۳– در MPLS باید قابلیت تجمع سازی ترافیک پشتیبانی شود . در این صورت امکان ارسال ترافیک های متنوع کاربران از طریق یک مسیر واحد فراهم می آید .

۴– MPLS باید قابلیت مسیریابی چند مسیره داشته باشد .

۵– سوئیچ های MPLS باید قابلیت برقراری ارتباط و تبادل اطلاعات با سایر سوئیچ های غیر MPLS را داشته باشند .

۶– MPLS باید قابلیت های یک پراکنی و چند پراکنی را پشتیبانی نماید .

۷– MPLS باید با مدل خدمات مجتمع IEFT شامل RSVP سازگار باشد .

۸– MPLS باید قابلیت مقیاس پذیری داشته باشد .

۹–  MPLS باید امکانات عملیاتی ، مدیریتی و نگه داری که در حال حاضر در شبکه های IP وجود دارد را پشتیبانی نماید .

 نحوه عملکرد MPLS

در شبکه های بدون اتصال ، هنگامی که بسته های ارسالی از مسیریاب های درون شبکه به سمت مقصد عبور می کنند ، هر مسیریاب براساس اطلاعات موجود در سرآیند بسته ها و با کمک الگوریتم مسیریابی لایه شبکه ، بسته ورودی را آنالیز می کند و پرش بعدی یا به عبارتی مسیریاب بعدی را ، که بسته باید به آن ارسال شود ، تعیین می کند . البته اطلاعات موجود در سرآیند بسته ها به مراتب از آنچه که فقط برای مسیریابی لازم است ، بیشتر می باشد .

می توان عملیات مسیریابی و تعیین پرش بعدی بسته ها را ترکیبی از دو عملیات مختلف تصور نمود .

عملیات اول ، دسته بندی بسته های ورودی به یک سری کلاس های معادل هدایت به جلو (FEC) می باشد . دومین عملیات ، نگاشت هر FEC به یک پرش بعدی است . طبیعی است که تمامی بسته هایی که به یک FEC یکسان نگاشت می یابند ، از یک مسیر واحد عبور می کنند تا به مقصد برسند .

 در الگوریتم های مسیریابی متداول IP ، چنانچه دو بسته دارای پیشوند آدرس مقصد یکسان باشند ، در این صورت از یک مسیر برای رسیدن به مقصد عبور می نمایند .

در شبکه های MPLS ، با کمک مسیریاب های برچسب مواد در لبه شبکه (LER)  ، بسته های ورودی به یک کلاس FEC خاص نگاشت می یابند و سپس هر FEC به یک مقدار عددی ثابت که آن را برچسب می نامیم ، نگاشت می یابد .

 بعد از این که بسته های ورودی به شبکه ، توسط LFR برچسب زده شد ، بسته های برچسب زده شده وارد شبکه می شوند . مسیریاب های موجود درون شبکه MPLS (LSR)  ، هیچ گونه آنالیزی بر روی اطلاعات موجود در سرآیند لایه سوم بسته ها نمی نمایند ،‌ بلکه فقط با توجه به مقدار برچسب هر بسته و با کمک جدول هدایت به جلو اقدام به تعیین پرش بعدی بسته می کنند . با توجه به این مطلب ، در مقایسه با مسیریابی در سطح لایه شبکه در شبکه های معمولی استفاده می شود ، MPLS دارای مزایای زیر می باشند :

۱-  می توان با استفاده از سوئیچ هایی که فقط براساس مقدار یک فیلد خاص ، عملیات سوئیچینگ را انجام می دهند ( مانند سوئیچ های ATM ) عملیات ارسال و هدایت بسته ها را در MPLS ، انجام داد .

۲-  با توجه به این که هر بسته ورودی به شبکه MPLS ، به یک کلاس FEC خاص نگاشت می یابد ، بنابراین مسیریاب های موجود در لبه شبکه ، می توانند از هر گونه اطلاعات موجود در سرآیند بسته های ورودی برای تعیین و اختصاص کلاس FEC یکسان استفاده نمایند . ( البته در مسیرباب های کناری شبکه MPLS ، معمولاً از فیلد آدرس IP مقصد بسته ها برای تعیین FEC استفاده می شود . )

۳-  چنانچه یک بسته ورودی واحد را از طریق دو مسیریاب متفاوت وارد شبکه MPLS نماییم ، در این صورت برچسبی را که دو مسیریاب به بسته ورودی اختصاص می دهند ، متفاوت با یکدیگر خواهد بود که این مطلب در پروتکل های متداول مسیریابی لایه سوم مشاهده نمی شود .

۴-  هر قدر عملیات اختصاص و نگاشت کلاس های FEC به بسته های ورودی پیچیده باشد ، هیچ گونه تأثیری بر روی عملکرد مسیریاب های درون شبکه نمی گذارد .

۵-  در برخی موارد برای انجام عملیات خاصی مانند نظارات و مهندسی ترافیکی ، باید بسته های ارسالی از یک مسیر خاص و از پیش تعیین شده عبور نمایند . در مسیریابی متداول لایه سوم ، با استفاده از مسیریابی مبدأ ، باید مسیر عبوری را صریحاً در سرآیند بسته های ارسالی مشخص نمود ، ولی از آنجایی که در MPLS برای هدایت بسته ها از برچسب استفاده می شود ، نیازی به این امر نمی باشد .

مسیریاب های متداول موجود ، با دریافت هر بسته ورودی به پردازش اطلاعات موجود در سرآیند آن می پردازند .

 البته این کار فقط برای تعیین پرش بعدی نمی باشد ، بلکه از آن برای استخراج سایر اطلاعات مورد نیاز مانند اولویت و کلاس خدمات بسته استفاده می شود .

 در MPLS می توان اطلاعات اولویت و کلاس خدمات بسته ها را در برچسب الحاقی به هر بسته نشان دهنده کلاس FEC است که بسته به آن تعلق دارد . فرض کنید که R1 و R2 و LSR داخلی شبکه باشند . بعد از مذاکره و توافق اولیه بین R1 و R2 ، فرض کنید که R1 تمام بسته هایی را که به کلاس FEC F نگاشت یافته است را با برچسب L به مسیریاب R2 ارسال می دارد .

 در این صورت برچسب L برای مسیریاب های R1 و R2 به ترتیب برچسب خروجی و برچسب ورودی نامیده می شوند . این برچسب فقط ارزش محلی دارد و نشان دهنده بسته های متعلق به کلاس FEC F ارسالی بین مسیریاب های R1 و R2 می باشد . به عبارت دیگر اگر در جایی دیگر از شبکه برچسب L استفاده شود ، دیگر الزاماً بسته های ارسالی به کلاس FEC F تعلق ندارند .

با توجه به این که ترافیک کاربر از R1 به سمت R2 ارسال می شود ، در اصطلاح به مسیریاب R1 و R2 به ترتیب مسیریاب های  « بالا جریان »  و   « پایین جریان »‌ گفته می شود .

 وظیفه عملیات اختصاص برچسب در MPLS به عهده مسیریاب « پایین جریان » می باشد . به عبارت دیگر می توان گفت که در MPLS عملیات اختصاص برچسب در جهت معکوس و از سمت مسیریاب « پایین جریان »‌ به سمت مسیریاب « بالای جریان » انجام می شود .

با استفاده از پروتکل LDP هر LSR شبکه اقدام به ارسال اطلاعات مربوط به برچسب های اختصاص یافته به کلاس های مختلف FEC ، به سایر LSR های شبکه می نماید .

 در اصطلاح به دو LSR ای که اطلاعات اختصاص برچسب را به یکدیگر مبادله می نمایند ، « همتای توزیع برچسب »‌ ، گفته می شود . تاکنون استانداردهای متعددی برای انجام عملیات توزیع برچسب در MPLS ارائه شده است ، که از بین آنها می توان به استانداردهای CR-LDP,LDP,RSVP-Tunnels,RSVP,BGP اشاره نمود .

چنانچه یک LSR شبکه از LSR مجاور خود درخواست ارسال لیستی از برچسب های اختصاص یافته به یک کلاس FEC خاص را بنماید ، در اصطلاح گفته می شود که عملیات توزیع برچسب درخواست بنا به درخواست مسیریاب « پایین جریان »‌ صورت می گیرد . البته در MPLS امکان ارسال لیست فوق بدون دریافت درخواست LSR مجاور نیز وجود دارد ، که در این حالت توزیع برچسب به صورت بدون درخواست مسیریاب « پایین جریان »‌ انجام می شود .

 هر شبکه MPLS معمولاً یکی و یا هر دو روش توزیع برچسب فوق را پشتیبانی می کند .

 پشته برچسب

 در MPLS ، برخی از بسته ها دارای چندین برچسب می باشند ، که به صورت یک پشته LIFO مدیریت می شوند .

 در این حالت سوئیچ های میانی شبکه فقط بالاترین برچسب موجود در پشته را پردازش می کنند و به مقادیر برچسب های قبلی و بعدی موجود در پشته توجهی ندارند .

 چنانچه پشته برچسب بسته ورودی خالی باشد

 ( در اصطلاح گفته می شود که عمق پشته صفر است ) در این صورت بسته دارای برچسب نمی باشد .

 در یک پشته برچسب به عمق m ، پایین ترین و بالاترین برچسب به ترتیب برچسب سطح ۱ و سطح m نامیده می شوند .

هنگام ورود یک بسته به سوئیچ های LSR ، واحدی به نام NHLFE وظیفه هدایت بسته ورودی به سمت سوئیچ بعدی را به عهده دارد.

 در NHLFE اطلاعات زیر موجود است :

  • پرش بعدی بسته:

شامل آرس مسیریاب بعدی که بسته جاری باید برای آن ارسال شود.

  • عملیاتی که باید بر پشته برچسب انجام شود:

این عملیات یکی از موارد زیر است :

–  جایگزینی بالاترین برچسب پشته با یک برچسب جدید

 – انجام عملیات POP بر روی پشته برچسب

– جایگزینی بالاترین برچسب پشته با یک برچسب جدید و سپس انجام عملیات Push یک یا چند برچسب جدید در پشته برچسب.

همچنین ممکن است که در NHLFE اطلاعات زیر نیز موجود باشد :

نحوه عملیات محصورسازی لایه دوم که در هنگام ارسال بسته استفاده می شود .

نحوه کد کردن پشته برچسب در هنگام ارسال بسته.

هر گونه اطلاعات لازم دیگر که برای مرتب سازی و هدایت بسته ها لازم است .

چنانچه یک LSR شبکه متوجه شود که پرش بعدی بسته ورودی ، خودش می باشد ، در این صورت عملیات POP را بر روی پشته برچسب بسته جاری انجام می دهد .

هر برچسب بسته ورودی ، به وسیله عملیات « نگاشت برچسب ورودی » (ILM) به مجموعه ای از NHLFE ها نگاشت می یابد .

 همچنین توسط عملیات مشابهی به نام  « نگاشت FEC به NHLFE »  هر FEC (FTN) ورودی به مجموعه ای از NHLFE ها نگاشت می یابد .

هنگامی که بسته ورودی فاقد برچسب باشد ، عملیات FTN بر روی آن انجام می شود و توسط این عملیات به بسته ورودی برچسب خاصی اختصاص داده می شود و سپس بسته ورودی هدایت می شود .

 عملیات جابجایی برچسب

 در MPLS هر LSR شبکه از روال های جابجایی برچسب ، برای هدایت بسته ها به سمت مقصد نهایی استفاده می کند .

 بدین منظور ، ابتدا بالاترین برچسب موجود در پشته برچسب بسته مورد پردازش قرار می گیرد . توسط عملیات ILM ، برچسب فوق به NHLFE نگاشت می یابد و سپس با کمک اطلاعات موجود در NHLFE ، پرش بعدی بسته و همچنین نوع عملیاتی که باید بر روی پشته برچسب انجام شود ، تعیین می شود .

چنانچه بسته ورودی به LSR فاقد برچسب باشد ، در این صورت با پردازش بر روی فیلدهای موجود در سرآیند لایه شبکه ، کلاس FEC بسته استخراج می شود و سپس با استفاده از FTN کلاس FEC بسته ورودی به یک NHLFE خاص نگاشت می یابد .

 با استخراج NHLFE ، می توان پرش بعدی بسته و همچنین نوع عملیات اعمالی بر روی پشته بسته را تعیین نمود .

کنترل LSP همان طور که قبلاً نیز اشاره گردید ، برای تعیین کلاس های FEC بسته های ورودی ، می توان از پیشوند آدرس های IP که توسط الگوریتم های مسیریابی دینامیک بین مسیریاب ها توزیع می شود ، استفاده کرد .

برای این نوع کلاس های FEC ، به دو صورت می توان LSP را تعیین نمود

که عبارتند از :

الف ) کنترل مستقل LSP

ب )   کنترل ترتیبی LSP

در روش کنترل مستقل LSP ، هر LSP شبکه مستقل از سایر LSP ها ، با توجه به کلاس FEC اختصاص یافته به بسته ورودی ، برچسب مناسب را به کلاس FEC اختصاص می دهد و سپس برچسب اختصاص یافته را به LSP همتای خود ارسال می کند .

طبیعی است که این گونه عملکرد در تعیین مسیر ، مشابه مسیریابیIP  می باشد که هر مسیریاب شبکه به طور مستقل اقدام به تعیین پرش بعدی بسته ورودی می نماید .

در روش کنترل ترتیبی LSP ، هر ‌ LSP شبکه ، در دو حالت زیر عملیات اختصاص برچسب به بسته ورودی را انجام می دهد :

– چنانچه LSP خروجی برای کلاس  FEC مشخص شده بسته ورودی ، خود  LSP جاری باشد .

– چنانچه قبلاً اطلاعات مربوط به اختصاص برچسب به FEC را از LSP پرش بعدی بسته های کلاس FEC دریافت کرده باشد .

در مواردی که ترافیک های متعلق به یک کلاس FEC خاص باید از یک مسیر مشخص با ویژگی های معین عبور نمایند ، از روش کنترل ترتیبی LSP استفاده می شود .

در روش کنترل مستقل LSP ، این احتمال وجود دارد که قبل از برقراری LSP ، ترافیک های متعلق به کلاس FEC وارد شبکه شوند و از یک مسیری که ممکن است ویژگی های ترافیکی مطلوب را نداشته باشد ، عبور کنند .

مجتمع سازی ترافیک

  یکی از روش های تقسیم بندی ترافیک به کلاس های مختلف FEC ، ایجاد FEC جداگانه برای هر یک از پیشوندهای آدرس IP موجود در جدول مسیریابی می باشد .

 بعد از تعیین کلاس های FEC  تمام ترافیک های وابسته به یک کلاس FEC   خاص از یک مسیر عبور می نمایند و به سمت مقصد نهایی هدایت می شوند .

در شبکه های MPLS این امکان وجود دارد که گروهی از کلاس های FEC  با یکدیگر ترکیب شوند و تشکیل یک گروه واحد را بدهند .

 در این حالت به تمام کلاس های FEC  موجود در یک گروه ، یک برچسب یکسان اختصاص داده می شود .

 به عبارت اختصاص برچسب به گروهی از FEC  ها که خود یک کلاس FEC   جدید می باشند ، مجتمع سازی ترافیک گفته می شود .

 طبیعی است که عملیات مجتمع سازی ترافیک ، باعث کاهش تعداد برچسب های مورد نیاز و همچنین کاهش میزان روال های کنترلی توزیع برچسب می گردد .

 انتخاب مسیر در MPLS

در شبکه های MPLS ، به نحوه انتخاب LSP برای یک کلاس FEC خاص ، انتخاب مسیر گفته می شود . در MPLS دو روش مختلف برای این کار موجود است که عبارتند از :

 مسیریابی پرش به پرش و مسیریابی صریح .

در مسیریابی پرش به پرش ، هر LSR شبکه مستقل از سایر LSR ها ، اقدام به تعیین پرش بعدی بسته های متعلق به کلاس FEC می نماید .

 امروزه در شبکه های IP ، از این روش برای انجام عملیات مسیریابی استفاده می شود .

در مسیریابی صریح ، همه LSR های شبکه در انتخاب مسیر و پرش های بعدی ، دخالت ندارند بلکه فقط یک LSR خاص که معمولاً LSR ورودی یا خروجی شبکه است ، اقدام به تعیین بخشی یا تمام مسیر LSR می کند . در کاربردهایی مانند مسیریابی نظارتی و همچنین مهندسی ترافیک ، از روش مسیریابی صریح استفاده می شود . در شبکه های MPLS ، در زمان اختصاص برچسب ، مسیر صریح مشخص می شود .

 زمان زندگی (TTL)

در مسیریابی متداول IP ، هر بسته ورودی دارای فیلدی به نام TTL است ، که با هر پرش بسته یکی از محتویات این فیلد کم می شود و در صورتی که مقدار فیلد فوق صفر شود ، بسته IP از بین می رود . باید ترتیب امکان محافظت شبکه در برابر حلقه های مسیریابی که از پیکره بندی غلط شبکه و یا از سرعت کم همگرایی الگوریتم مسیریابی شبکه ناشی می شود ، وجود دارد .

 در شبکه های MPLS ، برای جلوگیری از حلقه های مسیریابی و همچنین برای محدودسازی دامنه بسته های ارسالی ، از فیلد TTL استفاده می شود .

چنانچه از سرآیند « فاصله پرکن » ( سرآیندی که مستقل از سرآیندهای لایه دوم و لایه سوم می باشد و بین این دو سرآیند قرار می گیرد ) ، در بسته های MPLS استفاده شود ، در این صورت در داخل سرآیند فوق فیلدی به نام TTL وجود دارد که مقدار اولیه آن همان مقدار فیلد TTL سرآیند بسته های IP است . با عبور بسته از هر LSR شبکه ، مقدار فیلد TTL یکی کم می شود و هنگامی که بسته به LSR خروجی می رسد ، مقدار فیلد TTL موجود در سرآیند MPLS به فیلد TTL بسته های IP کپی می شود .

چنانچه از بخشی از سرآیند بسته های لایه دوم ( مثلاً فیلد VPI/VCI در سلول های ATM) به عنوان برچسب MPLS استفاده گردد ، در این صورت در هر پرش امکان کاهش یک واحدی TTL وجود ندارد. در این صورت به مسیری که دارای ویژگی فوق باشد ، مسیر LSP فاقد TTL گفته می شود .

 با توجه به این که در مسیرهای فاقد TTL ، نمی توان در هر پرش از محتوای فیلد TTL یک واحد کم نمود ، باید به نحو دیگری تعداد پرش های عبوری بسته در ناحیه های فاقد TTL مشخص شود .

 یکی از روش های انجام این کار ، این است که طول ناحیه فاقد TTL به اطلاع LSR ورودی رسانده شود . در این روش بسته هایی که وارد LSR ورودی می شوند و می خواهند از مسیر فاقد TTL عبور نمایند ، یکجا فیلد TTL آنها به اندازه طول ناحیه فاقد TTL ( تعداد مسیریاب های موجود در این مسیر ) کاهش می یابد . یکی از نکات مهمی که در مورد مسیرهای فاقد TTL باید مد نظر ، داشت آن است که سخت افزار لایه دوم این نواحی باید به مکانیسمی برای تشخیص حلقه های مسیریابی و رفع آنها مجهز باشد .

 استفاده از سوئیچ های ATM به عنوان LSR

 عملیات جابجایی برچسب در MPLS ، تا حد زیادی مشابه عملیات فوق در سوئیچ های ATM می باشد . با ورود هر سلول به سوئیچ های ATM ، ابتدا شماره درگاه ورودی و مقدار فیلد VPI/VCI آن بررسی می شود و سپس با کمک جدول خاصی ، عملیات اختصاص درگاه خروجی و VPI/VCI جدید انجام می گردد . بنابراین چنانچه بتوان از ناحیه VPI/VCI سلول های ATM به عنوان برچسب MPLS استفاده کرد ، در این صورت با افزودن نرم افزارهای مناسب به سوئیچ ATM ، می توان آنها را به LSR های شبکه MPLS تبدیل نمود .

روشهای  برچسب دهی MPLS در سرآیند

  سه روش مختلف برای قرار دادن برچسب MPLS در سرآیند بسته های ATM وجود دارد که عبارتند از :

– کدگذاری SVC :

در این حالت از فیلد VPI/VCI سلول های ATM به عنوان بالاترین برچسب موجود در ناحیه پشته بر چسب بسته های MPLS استفاده می شود .

 در این صورت LSP شبکه MPLS ، همانند مدارهای مجازی شبکه ATM می باشد و همچنین از پروتکل های سیگنالینگ ATM به عنوان پروتکل اختصاص و توزیع برچسب استفاده می شود در این حالت امکان PUSH  یا POP نمودن پشته برچسب وجود ندارد .

– کدگذاری SVP :

 در این حالت فقط از فیلد VPI سلول های ATM ، به عنوان بالاترین برچسب موجود در پشته برچسب بسته های MPLS استفاده می شود .

 می توان از فیلد VCI برای تعیین دومین برچسب موجود در ناحیه پشته برچسب استفاده کرد . برای انجام عملیات توزیع و اختصاص برچسب ، از پروتکل سیگنالینگ ATM استفاده می شود .

– کدگذاری چند نقطه ای SVP :

 مشابه حالت کدگذاری SVP می باشد با این تفاوت که از قسمت باقی مانده VCI برای مشخص نمودن نقطه ورودی LSP استفاده می شود .

 در این حالت امکان پیاده سازی اتصال های « چند نقطه به یک نقطه » موجود می باشد .

در شبکه های MPLS ، امکان این که در یک مسیر LSP از چندین روش کدگذاری برچسب استفاده شود وجود دارد . مثلاً می توان در بخشی از یک مسیر LSP ، از فیلد VPI/VCI سلول های ATM و در بخشی دیگر از سرآیند « فاصله پرکن » برای تعیین برچسب MPLS استفاده نمود            

ادغام برچسب

چنانچه یک LSR شبکه MPLS ، چندین برچسب ورودی مختلف را به یک کلاس FEC خاص اختصاص داده باشد ، طبیعی است که تمام بسته های متعلق به یک کلاس FEC یکسان باید دارای برچسب خروجی یکسان باشند ، بنابراین باید تمام برچسب های متعلق به یک کلاس FEC خاص ، به یک برچسب واحد محدود شوند .

 به این عملیات ،‌ ادغام برچسب گفته می شود .

 به عبارت دیگر می توان گفت که چنانچه یک LSR شبکه ، از درگاه های مختلف ورودی خود ، بسته هایی را با برچسب های مختلف ولی متعلق به یک کلاس FEC یکسان دریافت دارد ، در این صورت با کمک عملیات ادغام ، برچسب همه بسته های ورودی را با یک برچسب یکسان و از طریق یک درگاه خروجی واحد عبور می دهد .

چنانچه دو بسته ورودی متعلق به یک کلاس FEC یکسان ، با برچسب های متفاوت و از طریق درگاه های مختلف وارد یک LSR فاقد توانایی عملیات ادغام برچسب گردند ، در این صورت بسته های ورودی فوق با برچسب های متفاوت از LSR خارج می شوند . بنابراین می توان نتیجه گرفت که چنانچه LSR های شبکه قابلیت ادغام برچسب را داشته باشند ، در این صورت به هر کلاس FEC تنها یک برچسب خروجی نسبت داده می شود ؛ در حالی که چنانچه LSR قابلیت ادغام برچسب را نداشته باشد .

 در این صورت تعداد برچسب های اختصاص یافته به یک کلاس FEC خاص به مراتب بیشتر از یکی می باشد .

 تونل

 چنانچه مسیریاب های R1 و R2 ، دو مسیر یاب شبکه MPLS باشند که الزاماً در مسیر پرش به پرش بسته قرار ندارند ، مسیریاب R1 با استفاده از قابلیت تونل ، قادر به تحویل صریح بسته ورودی به مسیریاب R2 می باشد . به بسته های ارسالی از این مسیر ، بسته های تونلی گفته می شود . در شبکه های MPLS ، می توان تونل های LSP نیز پیاده سازی نمود . چنانچه یک مسیر LSP از <R1,R2,…Rn> تشکیل شده باشد که R1 مسیریاب نقطه ارسالی به تونل و Rn مسیریاب نقطه پایانی آن باشد ، در اصطلاح به این مسیر یک تونل LSP گفته می شود .

 

 

 

 

منبع سید مجتبی نجفی

نوشته شده به وسيله ramin_malek در شبکه ، ديدگاه ‌ها (438)

آموزش ترانک کردن Elastix و CUCM

http://www.alooiran.ir/%D8%A2%D9%85%D9%88%D8%B2%D8%B4-%D8%AA%D8%B5%D9%88%DB%8C%D8%B1%DB%8C-siptrunk-cucm-elastix.html

نوشته شده به وسيله ramin_malek در Voip ، ديدگاه ‌ها (1,529)

MTU چیست

MTU چیست ؟
این کلمه در اصطلاحات شبکه مخفف Maximum transmission unit به معنای حد اکثر واحد انتقال است.
در سیستم های ارتباط کامپیوتری برای انتقال اطلاعات آنها را در به پکتهایی تقسیم میکنند که توسط این پکتها اطلاعات به مقصد میرسد و این پکتها با توجه به بستر مخابراتی حجم متفاوتی میتوانند داشته باشند به صورت مثال در Ethernet به صورت پیش فرض سایز پکتها 1500 بایت میباشد.
این عدد در اکثر سیستم عامل ها و دیوایس های شبکه (لایه 3 و بالاتر) قابل تنظیم میباشد که در ویندوز XP فقط از طریق رجیستری میتوانید آن را تعیین نمایید.
در مورد PPPoE نیز حد اکثر قابل انتقال برای آن 1492 میباشد که این به خاطر آن است که باید از Ethernet عبور کند و مک آدرس ( 6 بایت) و Protocol-ID PPP ( 2 بایت ) نیز به آن اضافه میشود که نتیجه 1500-8=1492 میشود .
برای تغییر MTU در اینترفیس ها در ویندوز باید در رجیستری به آدرس زیر بروید.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Tcpip\Parameters\Interfaces\

که در آن شناسه کارت شبکه شما میباشد.
در این آدرس یک کلید رجیستری جدید از نوع DWORD به نام MTU بسازید و عدد دلخواه خود را در آ« به دسیمال وارد نمایید.

برای تغییر MTU در کانکشن PPPoE
باید به آدرس زیر در رجیستری بروید.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\Ndiswan\Parameters

در این شاخه برای تغییرات باید کلیک راست نموده از منوی New گزینه Key را انتخاب نمایید و نام آن را Protocols بگزارید
. درون آن باز گلید Key با نام 0 بسازید.
درون آن کلیدی از نوع DWORD ساخته بسازید با نام ProtocolType و سپس آن را ویرایش کرده و مقدار 800 را در مبنای hexadecimal بدهید.
کلیدی دیگر از نوع DWORD با نام PPPProtocolType بسازید و مقدار آن را در مبنای hexadecimal عدد 21 بدهید.
کلید دیگری از نوع DWORD با نام ProtocolMTU بسازید و مقدار مورد نظر برای MTU در مینای دسیمال بدهید.
برای اعمال تنظیمات ویندوز را باید یک بار ری استارت نمایید.

نوشته شده به وسيله ramin_malek در شبکه ، ديدگاه ‌ها (1,058)

How add Trusted Zone in node 32

http://kb.eset.com/esetkb/index?page=content&id=SOLN2351&locale=en_US

نوشته شده به وسيله ramin_malek در عمومی ، ديدگاه ‌ها (292)

انواع دوربین مدار بسته

http://www.rmalekghasemi.ir/file/camera.pdf

نوشته شده به وسيله ramin_malek در عمومی ، بدون ديدگاه

Sniff yahoo massenger Chat

http://www.rmalekghasemi.ir/file/Yahoo Messenger Monitor Sniffer 3.2 full.rar

نوشته شده به وسيله ramin_malek در هک و عملیات DDOS ، ديدگاه ‌ها (127)

 Parsitem